Skip to main content

  | मौसम…

411 समाचार
Public archive edition · Attributed source reporting with original dates · AI drafts are excluded

411 REFERENCE · Wikipedia

डोमेन नाम प्रणाली के रिकॉर्ड प्रकारों की सूची

Reference material by Wikipedia contributors. This retains its source identity and is not 411 news reporting.

डोमेन नाम प्रणाली के रिकॉर्ड प्रकारों की सूची डोमेन नाम प्रणाली (DNS) के ज़ोन फ़ाइलों में अनुमत संसाधन रिकॉर्ड (RR) का अवलोकन है। इसमें छद्म आरआर (RR) भी शामिल हैं। संसाधन रिकॉर्ड TypeType id. (decimal)Defining RFCDescriptionFunctionA1RFC 1035 http://tools.ietf.org/html/rfc1035#page-12 RFC 1035: Domain Names - Implementation and Specification Paul Mockapetris Paul Mockapetris November 1987 Network Working Group of the IETF (Internet Engineering Task Force) 12Address recordReturns a 32-bit IPv4 address, most commonly used to map hostnames to an IP address of the host, but it is also used for DNSBLs, storing subnet masks in RFC 1101, etc.AAAA28RFC 3596 http://tools.ietf.org/html/rfc3596#section-2 RFC 3596: DNS Extensions to Support IP Version 6 October 2003 The Internet SocietyIPv6 address recordReturns a 128-bit IPv6 address, most commonly used to map hostnames to an IP address of the host.AFSDB18RFC 1183AFS database recordLocation of database servers of an AFS cell. This record is commonly used by AFS clients to contact AFS cells outside their local domain. A subtype of this record is used by the obsolete DCE/DFS file system.APL42RFC 3123Address Prefix ListSpecify lists of address ranges, e.g. in CIDR format, for various address families. Experimental.CAA257RFC 6844Certification Authority AuthorizationDNS Certification Authority Authorization, constraining acceptable CAs for a host/domainCDNSKEY60RFC 7344Child copy of DNSKEY record, for transfer to parentCDS59RFC 7344Child DSChild copy of DS record, for transfer to parentCERT37RFC 4398Certificate recordStores PKIX, SPKI, PGP, etc.CNAME5RFC 1035Canonical name recordAlias of one name to another: the DNS lookup will continue by retrying the lookup with the new name.CSYNC62RFC 7477Child-to-Parent SynchronizationSpecify a synchronization mechanism between a child and a parent DNS zone. Typical example is declaring the same NS records in the parent and the child zoneDHCID49RFC 4701DHCP identifierUsed in conjunction with the FQDN option to DHCPDLV32769RFC 4431DNSSEC Lookaside Validation recordFor publishing DNSSEC trust anchors outside of the DNS delegation chain. Uses the same format as the DS record. RFC 5074 describes a way of using these records.DNAME39RFC 6672Delegation name recordAlias for a name and all its subnames, unlike CNAME, which is an alias for only the exact name. Like a CNAME record, the DNS lookup will continue by retrying the lookup with the new name.DNSKEY48RFC 4034DNS Key recordThe key record used in DNSSEC. Uses the same format as the KEY record.DS43RFC 4034Delegation signerThe record used to identify the DNSSEC signing key of a delegated zoneEUI48108RFC 7043MAC address (EUI-48)A 48-bit IEEE Extended Unique Identifier.EUI64109RFC 7043MAC address (EUI-64)A 64-bit IEEE Extended Unique Identifier.HINFO13RFC 8482Host InformationProviding Minimal-Sized Responses to DNS Queries That Have QTYPE=ANYHIP55RFC 8005Host Identity ProtocolMethod of separating the end-point identifier and locator roles of IP addresses.IPSECKEY45RFC 4025IPsec KeyKey record that can be used with IPsecKEY25RFC 2535RFC 2535, §3 and RFC 2930RFC 3445, §1. "The KEY RR was defined in RFC 2930..."Key recordUsed only for SIG(0) (RFC 2931) and TKEY (RFC 2930).RFC 2931, §2.4. "SIG(0) on the other hand, uses public key authentication, where the public keys are stored in DNS as KEY RRs and a private key is stored at the signer." RFC 3445 eliminated their use for application keys and limited their use to DNSSEC.RFC 3445, §1. "DNSSEC will be the only allowable sub-type for the KEY RR..." RFC 3755 designates DNSKEY as the replacement within DNSSEC.RFC 3755, §3. "DNSKEY will be the replacement for KEY, with the mnemonic indicating that these keys are not for application use, per RFC3445. RRSIG (Resource Record SIGnature) will replace SIG, and NSEC (Next SECure) will replace NXT. These new types completely replace the old types, except that SIG(0) RFC2931 and TKEY RFC2930 will continue to use SIG and KEY." RFC 4025 designates IPSECKEY as the replacement for use with IPsec.RFC 4025, Abstract. "This record replaces the functionality of the sub-type #4 of the KEY Resource Record, which has been obsoleted by RFC 3445."KX36RFC 2230Key Exchanger recordUsed with some cryptographic systems (not including DNSSEC) to identify a key management agent for the associated domain-name. Note that this has nothing to do with DNS Security. It is Informational status, rather than being on the IETF standards-track. It has always had limited deployment, but is still in use.LOC29RFC 1876Location recordSpecifies a geographical location associated with a domain nameMX15RFC 1035 and RFC 7505Mail exchange recordMaps a domain name to a list of message transfer agents for that domainNAPTR35RFC 3403Naming Authority PointerAllows regular-expression-based rewriting of domain names which can then be used as URIs, further domain names to lookups, etc.NS2RFC 1035Name server recordDelegates a DNS zone to use the given authoritative name serversNSEC47RFC 4034Next Secure recordPart of DNSSEC—used to prove a name does not exist. Uses the same format as the (obsolete) NXT record.NSEC350RFC 5155Next Secure record version 3An extension to DNSSEC that allows proof of nonexistence for a name without permitting zonewalkingNSEC3PARAM51RFC 5155NSEC3 parametersParameter record for use with NSEC3OPENPGPKEY61RFC 7929OpenPGP public key recordA DNS-based Authentication of Named Entities (DANE) method for publishing and locating OpenPGP public keys in DNS for a specific email address using an OPENPGPKEY DNS resource record.PTR12RFC 1035PTR Resource Record de PTR Resource RecordPointer to a canonical name. Unlike a CNAME, DNS processing stops and just the name is returned. The most common use is for implementing reverse DNS lookups, but other uses include such things as DNS-SD.RRSIG46RFC 4034DNSSEC signatureSignature for a DNSSEC-secured record set. Uses the same format as the SIG record.RP17RFC 1183Responsible PersonInformation about the responsible person(s) for the domain. Usually an email address with the @ replaced by a .SIG24RFC 2535SignatureSignature record used in SIG(0) (RFC 2931) and TKEY (RFC 2930). RFC 3755 designated RRSIG as the replacement for SIG for use within DNSSEC.SMIMEA53RFC 8162https://tools.ietf.org/html/rfc8162#section-2 RFC 8162 - Using Secure DNS to Associate Certificates with Domain Names for S/MIME May 2017 Internet Engineering Task Force 17 October 2018S/MIME cert associationhttps://www.iana.org/assignments/dns-parameters/dns-parameters.xhtml Domain Name System (DNS) Parameters September 2018 Internet Assigned Numbers Authority 17 October 2018Associates an S/MIME certificate with a domain name for sender authentication.SOA6RFC 1035 and RFC 2308The minimum field of SOA record is redefined to be the TTL of NXDOMAIN reply in RFC 2308.Start of [a zone of] authority recordSpecifies authoritative information about a DNS zone, including the primary name server, the email of the domain administrator, the domain serial number, and several timers relating to refreshing the zone.SRV33RFC 2782Service locatorGeneralized service location record, used for newer protocols instead of creating protocol-specific records such as MX.SSHFP44RFC 4255SSH Public Key FingerprintResource record for publishing SSH public host key fingerprints in the DNS System, in order to aid in verifying the authenticity of the host. RFC 6594 defines ECC SSH keys and SHA-256 hashes. See the IANA SSHFP RR parameters registry for details.TA32768DNSSEC Trust AuthoritiesPart of a deployment proposal for DNSSEC without a signed DNS root. See the IANA database and Weiler Spec for details. Uses the same format as the DS record.TKEY249RFC 2930Transaction Key recordA method of providing keying material to be used with TSIG that is encrypted under the public key in an accompanying KEY RR.RFC 2930, §6. "... the keying material is sent within the key data field of a TKEY RR encrypted under the public key in an accompanying KEY RR RFC 2535."TLSA52RFC 6698TLSA certificate associationA record for DANE. RFC 6698 defines "The TLSA DNS resource record is used to associate a TLS server certificate or public key with the domain name where the record is found, thus forming a 'TLSA certificate association'".TSIG250RFC 2845Transaction SignatureCan be used to authenticate dynamic updates as coming from an approved client, or to authenticate responses as coming from an approved recursive name serverRFC 2845, abstract similar to DNSSEC.TXT16RFC 1035Text recordOriginally for arbitrary human-readable text in a DNS record. Since the early 1990s, however, this record more often carries machine-readable data, such as specified by RFC 1464, opportunistic encryption, Sender Policy Framework, DKIM, DMARC, DNS-SD, etc.URI256RFC 7553Uniform Resource IdentifierCan be used for publishing mappings from hostnames to URIs.ZONEMD63TBAAssigned by IANA although the RFC is in draft status.SVCB64IETF DraftService BindingRR that improves performance for clients that need to resolve many resources to access a domain. More info in this IETF Draft by DNSOP Working group and Akamai technologies.HTTPS65IETF DraftHTTPS BindingRR that improves performance for clients that need to resolve many resources to access a domain. More info in this IETF Draft by DNSOP Working group and Akamai technologies. आगे के लेख पढ़ने के लिए श्रेणी:इंटरनेट प्रोटोकॉल श्रेणी:डोमेन नाम प्रणाली