Skip to main content

  | मौसम…

411 समाचार
Public archive edition · Attributed source reporting with original dates · AI drafts are excluded

411 REFERENCE · Wikipedia

ओपन शोर्टेस्ट पाथ फर्स्ट

Reference material by Wikipedia contributors. This retains its source identity and is not 411 news reporting.

ओपन शोर्टेस्ट पाथ फर्स्ट (OSPF) इंटरनेट प्रोटोकॉल (आईपी) नेटवर्क में इस्तेमाल में प्रयुक्त होने वाला एक डायनेमिक रूटिंग प्रोटोकॉल है। विशेष रूप से, यह एक लिंक स्टेट रूटिंग प्रोटोकॉल है जो एक ऑटोनॉमस प्रणाली (AS) में ऑपरेट करता है और इन्टीरियर गेटवे प्रोटोकॉल समूह के अंतर्गत आता है। IPv4 के लिए RFC 2328(1998) में यह OSPF Ver.2 के रूप में परिभाषित किया गया है। Moy J. OSPF Version 2 The Internet Society April 1998 RFC 2328 OSPFv2 2007-09-28 IPv6 के लिए अपडेट RFC5340(2008) के OSPF Ver.3 में दिए गए हैं। Coltun R. D. Ferguson, J Moy, A. Lindem OSPF for IPv6 The Internet Society July 2008 RFC 5340 OSPFv3 2008-07-23 OSPF शायद सबसे व्यापक रूप से इस्तेमाल होने वाला इन्टीरियर गेटवे प्रोटोकॉल(IGP) है जो बड़े व्यापारिक संस्थानों के नेटवर्क में प्रयुक्त होता है। IS-IS, एक और लिंक स्टेट रूटिंग प्रोटोकॉल है, जो आम तौर पर बड़े सर्विस प्रोवाईडर नेटवर्क में प्रयुक्त होता है। बॉर्डर गेटवे प्रोटोकॉल (BGP) सबसे अधिक इस्तेमाल किया जाने वाला एक्स्टीरियर गेटवे प्रोटोकॉल है जो इन्टरनेट पर विभिन्न सिस्टमों के बीच में प्रमुख प्रोटोकॉल है। समीक्षा OSPF एक इन्टीरियर गेटवे प्रोटोकॉल है जो पूर्ण रूप से एक सिंगल रूटिंग डोमेन (स्वतः निर्देशित सिस्टम) में इन्टरनेट प्रोटोकॉल पैकेटस् भेजता है। यह उपलब्ध रूटर्स से लिंक स्टेट सूचना इकट्ठा करता है तथा नेटवर्क का एक टोपोलॉजी मानचित्र बनाता है। टोपोलॉजी इंटरनेट लेयर में रूटिंग टेबल को निर्धारित करती है जिस से IP डाटाग्राम में दिए गए IP एड्रेस के आधार पर स्वतः रूटिंग का निर्धारण होता है। OSPF को अलग-2 लम्बाई की सबनेट मास्किंग (VLSM) और क्लास-लैस इंटर डोमेन रूटिंग (CIDR) एड्रेस मॉडलों की सहायता करने के लिए डिज़ाइन किया गया था। OSPF टोपोलॉजी में आए बदलावों को तुंरत खोजता है जैसे कि लिंक का फ़ेल होना इत्यादि, तथा कुछ ही सेकंड के भीतर इसे एक नए लूप-रहित रूटिंग स्ट्रक्चर से जोड़ देता है। यह दिज्क्स्त्रा एल्गोरिथ्म पर आधारित पद्धति का उपयोग करके हर रूट के लिए एक सबसे छोटी पाथ श्रृंखला बनाता है, जिसे शोर्टेस्ट पाथ फर्स्ट एल्गोरिथ्म के नाम से जाना जाता है। लिंक स्टेट सूचना प्रत्येक रूटर पर लिंक स्टेट डाटाबेस के रूप में रखी जाती है (LSDB) जो सम्पूर्ण नेटवर्क टोपोलोजी की ट्री इमेज है। LSDB की इसी तरह की प्रतियां समय समय पर सभी OSPF रूटर को डाटा भेज कर अपडेट की जाती हैं। OSPF रूटिंग नीतियों द्वारा बनाई गयी रूट टेबल को प्रत्येक रूटिंग इंटरफेस से जुड़े कॉस्ट फेक्टर्स (बाह्य मीट्रिक्स) द्वारा नियंत्रित किया जाता है। कॉस्ट फेक्टर (लागत कारक) एक रूटर तक की दूरी (राउंड ट्रिप समय), एक लिंक का नेटवर्क थ्रूपुट, या लिंक की उपलब्धता और विश्वसनीयता, हो सकता है जिसे एक संख्या के रूप में (बिना किसी यूनिट के) दर्शाया जाता है। यह समान मूल्यों वाले रूटों पर ट्रैफिक भार का संतुलन बनाने के लिए एक डायनेमिक प्रोसेस प्रदान करता है। एक OSPF नेटवर्क तैयार किया जा सकता है, या प्रबंधन को सरल करने तथा ट्रैफिक तथा संसाधनों का सदुपयोग नियोजित करने के लिए रूटिंग क्षेत्रों में पुर्नविभाजित किया जा सकता है। क्षेत्रों की पहचान 32-बिट नम्बरों के आधार पर होती है। जिन्हें सामान्यतयः सिर्फ दशमलव में, या अक्सर ओकटेट पर आधारित डॉट-डेसीमल नोटेशन, से प्रदर्शित किया जाता है जो IPv4 एड्रेस नोटेशन से परिचित होते हैं। मुख्यतः, क्षेत्र 0 (शून्य) या 0.0.0.0 कोर या एक OSPF नेटवर्क के आधार क्षेत्र का प्रतिनिधित्व करता है। अन्य क्षेत्रों की पहचान इच्छानुसार की जा सकती है, सामान्यतयः किसी क्षेत्र की पहचान के लिए, एडमिनिस्ट्रेटर उस क्षेत्र के मुख्य रूटर का IP एड्रेस चुनता है। प्रत्येक अतिरिक्त क्षेत्र का OSPF आधार क्षेत्र के साथ सीधा या आभासी कनेक्शन होना चाहिए। इस तरह के कनेक्शन एक इंटरकनेक्टिंग रूटर द्वारा स्थापित किये जाते हैं जिसे एरिया बॉर्डर रूटर (ABR) के रूप में जाना जाता है। एक ABR प्रत्येक क्षेत्र में अलग लिंक स्टेट डाटाबेस बनाता है और एक नेटवर्क में सभी क्षेत्रों के लिए रूटों का सार बनाता है। OSPF TCP/IP ट्रांसपोर्ट प्रोटोकॉल (UDP, TCP) का प्रयोग नहीं करता, लेकिन इसे IP डाटाग्राम्स में प्रोटोकॉल नं 89 के साथ समझाया गया है। यह दूसरे रूटिंग प्रोटोकॉल जैसे कि रूटिंग इन्फोर्मेशन प्रोटोकॉल (RIP), या बॉर्डर गेटवे प्रोटोकॉल (BGP) के विपरीत कार्य करता है। OSPF त्रुटियों का पता लगाने तथा सुधार करने का कार्य खुद करता है। एक ब्रॉडकास्ट नेटवर्क लिंक पर रूटों की बौछार के लिए OSPF मल्टीकास्ट एड्रेसिंग का प्रयोग करता है। नॉन-ब्रॉडकास्ट नेटवर्क के लिए पड़ोसी ब्रॉडकास्ट की खोज का विशेष प्रावधान है। OSPF मल्टीकास्ट IP पैकेट्स कभी IP रूटर्स के पार नहीं जाते, वे एक से अधिक हॉप कभी भी नहीं करते. OSPF, RFC 2328 में दिए गए निर्देशों के अनुसार मल्टीकास्ट एड्रेस 224.0.0.5 (सभी SPF/ लिंक स्टेट रूटर्स, जिन्हें AllSPFरौतेर्स के रूप में भी जाना जाता है) और 224.0.0.6 (सभी मनोनीत रूटर्स, AllDरौतेर्स), आरक्षित रखता है। मल्टीकास्ट IP ट्रैफिक की रूटिंग के लिए, OSPF मल्टीकास्ट ओपन शोर्टेस्ट पाथ फर्स्ट प्रोटोकॉल (MOSPF) का सहयोग करता है, जैसा कि RFC 1584 में बताया गया है।RFC 1584, मल्टीकास्ट एक्सटेंशन्स टू OSPF, जे मोए, द इंटरनेट सोसाइटी (मार्च 1994) IPv4 पर चलते समय OSPF प्रोटोकॉल, वैकल्पिक प्रमाणीकरण तरीकों का प्रयोग करते हुए सुरक्षित रूप से रूटर्स के बीच काम करता है, तथा केवल विश्वसनीय रूटर्स को रूटिंग में भाग लेने की अनुमति देता है। OSPFv3, जो IPv6 पर चलता है, अब प्रोटोकॉल-इन्टरनल प्रमाणीकरण का समर्थन नहीं करता. इसके बजाय, यह IPv6 प्रोटोकॉल सुरक्षा (IPsec) पर निर्भर करता है। OSPF के तीसरे संस्करण में IPv4 प्रोटोकॉल के कार्यान्वयन के लिए संशोधन दिए गए हैं। आभासी लिंक्स के अलावा, सभी पड़ोसी एक्सचेंज IPv6 लिंक-लोकल एड्रेसिंग का प्रयोग करते हैं। IPv6 प्रोटोकॉल सबनेट पर आधारित होने के बजाए प्रति लिंक चलता है। प्रोटोकॉल को मूलतः स्वतंत्र प्रोटोकॉल बनाने के लिए लिंक-स्टेट विज्ञापनों तथा हैलो डिस्कवरी पैकेट्स में से सभी IP प्रीफिक्स सूचना हटा दी गयी है। IP-IPv6 में IP एड्रेसिंग का 128 बिट तक करने के बावज़ूद क्षेत्र तथा रूटर की पहचान अभी भी 32-bit वैल्यू पर आधारित हैं। पड़ोसी संबंध रूटर्स एक ही ब्रॉडकास्ट डोमेन में या पॉइंट टू पॉइंट टेलीकम्युनिकेशन लिंक में प्रत्येक सिरे पर, समीपवर्ती रूटर का पता लगा कर प्रतिक्रिया करते हैं। यह पता तब लगता है जब रूटर खुद को हैलो OSPF प्रोटोकॉल पैकेट में देखते हैं। इसे टू वे स्टेट कहा जाता है तथा यह सर्वाधिक बुनियादी रिश्ता है। एक ईथरनेट या फ्रेम रिले नेटवर्क में रूटर्स एक डेसिगनेटेड रूटर (DR) और एक बैकअप डेसिगनेटेड रूटर (BDR) को चुनते हैं जो रूटर्स के बीच ट्रैफिक कम करने के लिए हब की तरह कार्य करता है। OSPF दोनों यूनीकास्ट और मल्टीकास्ट का प्रयोग "हैलो पैकेट" भेजने और लिंक स्टेट को अपडेट करने के लिए करता है। एक लिंक स्टेट रूटिंग प्रोटोकॉल के रूप में, OSPF दूसरे रूटर्स के साथ रूटिंग अपडेट लेने/देने के लिए सम्बन्ध स्थापित करता है। OSPF में पड़ोसी टेबल को एड्जेसेंसी टेबल कहा जाता है। OSPF केवल सीधे जुड़े हुए रूटर्स के साथ सम्बन्ध बनाता है बशर्ते कि OSPF सही ढंग से व्यवस्थित हो। जिन रूटर्स के साथ यह सम्बन्ध बनाता है वह इंटरफेस के साथ समान क्षेत्र में होने चाहियें. एक इंटरफेस सिर्फ एक ही क्षेत्र से सम्बंधित हो सकता है। क्षेत्र के प्रकार एक OSPF नेटवर्क क्षेत्रों में बंटा होता है जिन पर 32-बिट क्षेत्र पहचान का लेबल लगा होता है। क्षेत्र पहचान चिन्ह ज्यादातर (हमेशा नहीं) एक IPv4 एड्रेस के डॉट डेसीमल नोटेशन के रूप में लिखे जाते हैं। हालांकि, ये IP पते नहीं हैं और बिना दिक्कत के किसी भी IPv4 एड्रेस की नकल कर सकते हैं। OSPF (OSPFv3) के IPv6 कार्यान्वन के लिए क्षेत्र पहचानने के लिए भी इसी नोटेशन में लिखे 32-bit पहचान चिन्हों का प्रयोग किया जाता है। यद्यपि ज्यादातर OSPF दूसरे क्षेत्र नंबर जो डॉटेड डेसीमल फॉर्मेट (उदाहरण क्षेत्र 1) में नहीं लिखा हो, के साथ सम्बन्ध स्थापित करेंगे, फिर भी हमेशा डॉटेड-डेसीमल का प्रयोग करना ठीक रहता है। ज्यादातर इम्प्लेमेंटेशन क्षेत्र 1 का क्षेत्र पहचान विस्तार 0.0.0.1 तक कर देते हैं किन्तु कुछ का विस्तार 1.0.0.0 तक भी किया गया है। क्षेत्र होस्ट तथा नेटवर्क के लोजिकल समूह हैं, जिस में नेटवर्क में इंटरफेस द्वारा जुड़े हुए रूटर्स भी शामिल हैं। प्रत्येक क्षेत्र एक अलग लिंक स्टेट डाटाबेस रखता है सार जुड़े हुए रूटर द्वारा बाकी नेटवर्क की ओर भेजा जा सकता है। इस प्रकार एक क्षेत्र की टोपोलॉजी क्षेत्र के बाहर अज्ञात रहती है। यह एक ऑटोनोमस प्रणाली के भागों के बीच रूटिंग ट्रैफिक को कम कर देता है। कई "विशेष" क्षेत्र के प्रकार परिभाषित किये गये हैं: बैकबोन एरिया बैकबोन क्षेत्र (क्षेत्र 0 या क्षेत्र 0.0.0.0 के रूप में भी जाना जाता है) एक OSPF नेटवर्क का प्रमुख हिस्सा है। अन्य सभी क्षेत्र इससे जुड़े हैं और इंटर एरिया रूटिंग बैकबोन एरिया से जुड़े रूटर्स तथा उनसे सम्बंधित क्षेत्रों द्वारा होती है। यह 'OSPF डोमेन' की लोजिकल और शारीरिक संरचना है और OSPF डोमेन में सभी नॉनज़ीरो क्षेत्रों से जुड़ी है। ध्यान दें कि OSPF में ऑटोनोमस सिस्टम बॉर्डर रूटर (ASBR) शब्द इस अर्थ में ऐतिहासिक है, कि कई OSPF डोमेन समान इंटरनेट ऑटोनोमस, RFC1996 में एक साथ हो सकते हैं। ASGuidelines 1996 25 Hawkinson J T. Bates Guidelines for creation, selection, and registration of an Autonomous System Internet Engineering Task Force March 1996 ftp://ftp.rfc-editor.org/in-notes/rfc1930.txt ASguidelines 2007-09-28 https://web.archive.org/web/20200722232936/ftp://ftp.rfc-editor.org/in-notes/rfc1930.txt 22 जुलाई 2020 dead बैकबोन क्षेत्र नॉन बैकबोन क्षेत्रों के बीच रूटिंग सूचना के वितरण के लिए जिम्मेदार है। बैकबोन क्षेत्र आस पास होने चाहियें लेकिन इन्हें भौतिक रूप में आस पास होने की जरूरत नहीं है। बैकबोन संपर्क आभासी लिंक्स को नियोजित कर के स्थापित किये जा सकते हैं। सभी OSPF क्षेत्र बैकबोन क्षेत्र से अवश्य जुड़े हुए होने चाहियें. बहरहाल, यह संबंध एक आभासी लिंक के माध्यम से हो सकता है। उदाहरण के लिए मान लो कि, 0.0.0.1 क्षेत्र का 0.0.0.0 क्षेत्र के साथ भौतिक सम्बन्ध है। इसके अलावा क्षेत्र 0.0.0.2 का बैकबोन से कोई सीधा संबंध नहीं है, लेकिन यह 0.0.0.1 क्षेत्र से जुड़ा हुआ है। 0.0.0.2 क्षेत्र बैकबोन तक पहुँचने के लिए ट्रांजिट 0.0.0.1 क्षेत्र के माध्यम से एक आभासी लिंक का प्रयोग कर सकता है। ट्रांसिट क्षेत्र बनने के लिए, एक क्षेत्र में ट्रांसिट विशेषताओं का होना जरूरी है इसलिए यह किसी भी तरह से रुकावट पैदा करने वाला नहीं हो सकता. रुकावट क्षेत्र रुकावट क्षेत्र एक ऐसा क्षेत्र है, जो बाहरी ऑटोनोमस प्रणाली (AS) से रूट विज्ञापन प्राप्त नहीं करता तथा क्षेत्र के भीतर होने वाली रूटिंग पूरी तरह से एक डिफ़ॉल्ट रूट पर आधारित होती है। इस से क्षेत्र के इन्टरनल रूटर्स के रूटिंग डाटाबेस का आकर छोटा हो जाता है। रुकावट क्षेत्रों की बुनियादी अवधारणा में संशोधन से कम रुकावट वाला क्षेत्र (NSSA) बना है। इसके अलावा, सिस्टम वेंडरों द्वारा कई सुविधानुसार बदलाव लागू किये गए हैं, जैसे पूरी तरह से रुकावट वाला क्षेत्र (TSA) और NSSA पूरी तरह से रुकावट वाला क्षेत्र . दोनों सिस्को सिस्टम्स रूटिंग उपकरण का विस्तार हैं। कम रुकावट वाला क्षेत्र एक कम रुकावट वाला क्षेत्र (NSSA) रुकावट क्षेत्र का एक प्रकार है जो ऑटोनोमस प्रणाली के बाहरी रूटों को पकड़ सकता हैं और उन्हें अन्य क्षेत्रों में भेज सकता है, लेकिन फिर भी अन्य क्षेत्रों से AS बाहरी रूट प्राप्त नहीं कर सकता. NSSA रुकावट क्षेत्र का विस्तृत रूप है जो रुकावट क्षेत्र में सीमित मात्रा में बाहरी रूटों को आने देता है। सुविधानुसार एक्सटेंशन पूरी तरह से रुकावट वाला क्षेत्र सिस्को सिस्टम्स रूटरस में एक पूरी तरह से रुकावट वाला क्षेत्र,OSPF क्षेत्र और वर्चुअल लिंक्स क्या हैं?, https://web.archive.org/web/20120203140007/http://www.cisco.com/warp/public/104/8.html 3 फ़रवरी 2012 सिस्को डॉक्युमेंट आईडी: 13703, दिसम्बर 2005 एक रुकावट क्षेत्र के समान है। हालांकि, यह क्षेत्र बाह्य रूटों के अतिरिक्त सम्मरी रूटों को भी अनुमति नहीं देता अथार्त इंटर क्षेत्र (IA) रूटों का पूर्ण रुकावट क्षेत्र में सारांश नहीं बनता. ट्रैफिक के लिए एकमात्र तरीका क्षेत्र के बाहर डिफॉल्ट रूट है जो उस क्षेत्र में अकेला विज्ञापित टाइप-3 LSA है। जब वहाँ से बाहर के क्षेत्र का एक ही रास्ता है, रूट प्रोसेसर को कम रूटिंग निर्णय लेने पड़ते हैं जिस से सिस्टम के संसाधनों की उपयोगिता में कमी आती है। कभी कभी, यह कहा जाता है कि एक TSA के पास केवल एक ABR हो सकता है।May 2009 यह सच नहीं है| यदि एक से अधिक ABR हैं, जो कि उच्च उपलब्धता के लिए आवश्यक हो सकते हैं, TSA के इन्टीरियर रूटर्स ABR को सबसे कम इंट्रा-क्षेत्र मीट्रिक के साथ नॉन-इंट्रा-क्षेत्र ट्रैफिक भेजेंगे ("निकटतम" ABR को). NSSA सम्पूर्ण रुकावट वाला क्षेत्र सिस्को सिस्टम्स NSSA के स्वामित्व संस्करण को भी लागू करता है जिसे NSSA सम्पूर्ण रुकावट वाला क्षेत्र कहा जाता है। यह TSA की विशेषताओं के अनुसार चलता है अथार्त इस प्रकार के क्षेत्र में टाइप 3 और टाइप 4 सारांश रूटों की बौछार नहीं होती. यह भी संभव है कि एक क्षेत्र सम्पूर्ण रुकावट तथा कम रुकावट वाला हो जिसका अर्थ है क्षेत्र 0.0.0.0 से केवल डिफॉल्ट रूट मिलेगा, लेकिन इसमें एक ऑटोनोमस सिस्टम बॉर्डर रूटर () हो सकता है जो बाह्य रूटिंग सूचना को प्राप्त करता है और इसे लोकल क्षेत्र में भेजता है तथा इसी प्रकार लोकल क्षेत्र से क्षेत्र 0.0.0.0 को भेजता है। एक NSSA क्षेत्र में पुनर्वितरण एक विशेष प्रकार का LSA बनाता है जिसे टाइप 7 के रूप में जाना जाता है जो केवल एक NSSA क्षेत्र में मौजूद हो सकता है। एक NSSA ASBR इस LSA को उत्पन्न करता है और एक NSSA ABR रूटर इसे टाइप 5 LSA में रूपांतरित करता है जो OSPF डोमेन में मिल जाता है। एक क्षेत्र एक साथ कम रुकावट तथा सम्पूर्ण रुकावट वाला हो सकता है। यह तब होता है जब किसी व्यावहारिक जगह पर एक ASBR सम्पूर्ण रुकावट के छोर पर रखा जाता है। उदाहरण के लिए - नयी अधिगृहित कंपनी के साथ. ऐसे मामले में, ASBR बाह्य रूटों को सम्पूर्ण रुकावट क्षेत्र में भेजता है, और वे उस क्षेत्र में OSPF स्पीकर के लिए उपलब्ध रहते हैं। सिस्को किर्यान्वन में बाहरी रूटों को सम्पूर्ण रुकावट क्षेत्र में भेजने से पहले सारबद्ध किया जा सकता है। सामान्य रूप से, ASBR को TSA-NSSA को प्रक्षेपण नहीं करना चाहिए, हालांकि बहुत ही सावधानी से डिजाइन और संचालन के साथ सीमित विशेष मामलों में ऐसा हो सकता है जिनमें इस तरह के प्रक्षेपण का कोई अर्थ हो। सम्पूर्ण रुकावट क्षेत्र को NSSA के रूप में घोषित करने से, डिफॉल्ट रूट के अलावा बैकबोन से कोई बाह्य रूट क्षेत्र में प्रवेश नहीं कर सकता. TSA-NSSA के द्वारा बाह्य रूट 0.0.0.0 क्षेत्र पहुँचते हैं लेकिन डिफॉल्ट रूट के अलावा अन्य कोई रूट TSA-NSSA में प्रवेश नहीं करता. TSA-NSSA के रूटर्स ASBR द्वारा प्रक्षेपित रूटों को छोड़ कर सारे ट्रैफिक को ABR को भेज देते हैं। ट्रांजिट क्षेत्र एक ट्रांजिट क्षेत्र में दो या अधिक OSPF बॉर्डर रूटर होते हैं और यह एक क्षेत्र से दूसरे समीपवर्ती क्षेत्र को ट्रैफिक भेजने में प्रयोग किया जाता है। ट्रांजिट क्षेत्र इस ट्रैफिक को उत्पन्न नहीं करता तथा इस प्रकार के ट्रैफिक का गंतव्य नहीं होता। पाथ वरीयता OSPF रूट लागत को अपनी बुनियादी रूटिंग मीट्रिक के रूप में प्रयोग करता है, जो मानक द्वारा परिभाषित के लिए किसी भी मानक मूल्य जैसे कि गति के समान नहीं है, इसलिए नेटवर्क डिजाइनर डिजाईन के अनुरूप मीट्रिक ले सकता है। व्यवहारिक रूप में, यह दिए गए रूट एड्रेस के इंटरफेस की गति (बैंडविड्थ) द्वारा मापी जाती है, यद्यपि अब नेटवर्क के लिए विशेष मापन कारकों की आवश्यकता है क्योंकि 100 Mbit/s से तेज लिंक आम बात है। सिस्को 10^8/बैंडविड्थ (बेस की डिफ़ॉल्ट वैल्यू 10^8, नियोजित की जा सकती है) मीट्रिक का प्रयोग करता है। इसलिए एक 100Mbit/s की लागत 1 होगी, 10Mbit/s की लागत 10 होगी और इसी प्रकार गणना की जायेगी. 100Mbit से भी तेज लिंक के लिए लागत 1 से कम होगी। यद्यपि मीट्रिक्स की तुलना केवल तब हो सकती है जब वे समान प्रकार के हों. मीट्रिक्स चार प्रकार के होते हैं, जिन्हें प्राथमिकता के क्रम में नीचे सूचीबद्ध किया गया है। मीट्रिक पर ध्यान दिए बिना एक इंट्रा-क्षेत्र रूट को एक इंटर-क्षेत्र रूट के मुकाबले हमेशा प्राथमिकता दी जाती है तथा ऐसा ही अन्य प्रकारों (टाइप) के साथ किया जाता है। इंट्रा क्षेत्र इंटर क्षेत्र एक्सटर्नल टाइप 1, जिसमें बाह्य रूट लागत और ASBR तक इन्टरनल पथ की लागत शामिल है जो रूट को प्रक्षेपित करता है। एक्सटर्नल टाइप 2, जिसका मूल्य केवल बाह्य पथ लागत है। ट्रैफिक इंजीनियरिंग OSPF-TE OSPF का विस्तृत रूप है जो ट्रैफिक इंजीनियरिंग की गति को तेज़ करने तथा इसे नॉन-IP नेटवर्क पर प्रयोग की अनुमति देता है (RFC 3630)। Katz D D. Yeung Traffic Engineering (TE) Extensions to OSPF Version 2 The Internet Society September 2003 RFC 3630 OSPF-TEextensions 2007-09-28 टोपोलॉजी के बारे में अधिक जानकारी ओपेक LSA, जिसमें टाइप-लंबाई-मूल्य की जानकारी होती है, से मिल सकती है। ये विस्तार OSPF-TE को पूरी तरह से डाटा प्लेन नेटवर्क के बैंड से बाहर चलने की अनुमति देते हैं। इसका अर्थ यह है कि इसका नॉन-IP नेटवर्क जैसे कि ऑप्टिकल नेटवर्क में भी प्रयोग किया जा सकता है। OSPF-TE मुख्यतः GMPLS नेटवर्कों में एक टोपोलॉजी का वर्णन करता है, जिस पर GMPLS पाथ स्थापित किया जा सकता है। इसके पश्चात् पूरे नेटवर्क के मानचित्र का उपयोग करके GMPLS अपना पाथ सेटअप और फोर्वर्डिंग प्रोटोकॉल का प्रयोग करता है। अन्य एक्सटेंशन RFC 3717 डोक्युमेंट IP के लिए ऑप्टिकल रूट में काम करते हैं, जो OSPF तथा IS-IS के "रुकावट पर आधारित" एक्सटेंशन पर आधारित है। Rajagopalan B J. Luciani & D. Awduche IP over Optical Networks: A Framework Internet Engineering Task Force March 2004 RFC 3717 OSPFoverOptical 2007-09-28 OSPF रूटर के प्रकार OSPF निम्नलिखित प्रकार के रूटर परिभाषित करता है: एरिया बॉर्डर रूटर (ABR) ऑटोनोमस सिस्टम बॉर्डर रूटर (ASBR) इन्टरनल रूटर (IR) बैकबोन रूटर (BR) रूटर के प्रकार एक OSPF प्रक्रिया की विशेषताएं हैं। एक रूटर में एक या एक से अधिक OSPF प्रक्रियाएँ हो सकती है। उदाहरण के लिए, एक रूटर जो एक से अधिक क्षेत्र से जुड़ा है और जो एक दूसरे AS से जुड़े BGP प्रक्रिया से रूट प्राप्त करता है, एक ABR और एक ASBR, दोनों प्रकार का है। प्रत्येक रूटर में पहचान करने की क्षमता है, जिसे सामान्यतः IP एड्रेस के डॉटेड डेसीमल फॉर्मेट में लिखा जाता है (जैसे: 1.2.3.4)। इस आईडी एक OSPF प्रक्रिया के लिए नियोजित होनी चाहिए। यदि स्पष्ट रूप से नियोजित नहीं है, तो सबसे बड़ा लोजिकल IP एड्रेस रूटर ID की भूमिका ग्रहण करेगा। अगर कोई लोजिकल/लूपबेक IP एड्रेस न हो तो किसी सक्रिय फिजीकल इन्टरफेस का सबसे बड़ा IP एड्रेस रूटर ID की भूमिका ग्रहण करेगा। रूटर आईडी को नेटवर्क में सबनेट का हिस्सा बनने की आवश्यकता नहीं है तथा अक्सर भ्रम से बचने के लिए ऐसा किया जाता है। नोट: रूटर प्रकारों को पढ़ते समय डेसिगनेटेड रूटर (DR) अथवा बैकअप डेसिगनेटेड रूटर (BDR) से भ्रमित न हों जो एक रूटर के तत्त्व हैं न कि स्वयं रूटर. एरिया बॉर्डर रूटर ABR एक रूटर है जो एक या अधिक OSPF क्षेत्रों को मुख्य बैकबोन नेटवर्क से जोड़ता है। यह उन सभी क्षेत्रों, जिनसे यह जुड़ा हुआ है, का एक सदस्य माना जाता है। एक ABR मेमोरी में लिंक स्टेट डाटाबेस की कई प्रतियां रखता है, हर क्षेत्र के लिए एक जिससे वह रूटर जुड़ा हुआ है। ऑटोनोमस सिस्टम बाऊंड्री रूटर ASBR एक रूटर है जो एक से अधिक AS से जुड़ा है और जो दूसरे AS में रूटर्स को रूटिंग जानकारी भेजता है। ASBRs आमतौर पर नॉन IGP रूटिंग प्रोटोकॉल (जैसे, BGP), या स्टेटिक रूट अथवा दोनों का प्रयोग करता है। . ASBR का प्रयोग अपने AS के द्वारा दूसरे As से प्राप्त रूटों को वितरित करने में किया जाता है। इन्टरनल रूटर IR एक रूटर है जिसके सारे इंटरफेस एक ही क्षेत्र में होते है। बैकबोन रूटर बैकबोन रूटर्स : ये रूटर OSPF बैकबोन का एक हिस्सा हैं। परिभाषा के अनुसार, इनमें सभी एरिया बॉर्डर रूटर्स भी शामिल हैं, क्योंकि वे क्षेत्रों के बीच की रूटिंग जानकारी देते हैं। हालांकि, एक बैकबोन रूटर एक ऐसा रूटर भी हो सकता है जो केवल दूसरे बैकबोन एक रूटर (या एरिया बॉर्डर) से जुड़ा हो तथा इसीलिए किसी भी क्षेत्र का हिस्सा न हो (0 क्षेत्र के अलावा)। ध्यान दें कि: एक एरिया बॉर्डर रूटर हमेशा एक बैकबोन रूटर है, लेकिन एक बैकबोन रूटर का एरिया बॉर्डर रूटर होना जरूरी नहीं है। डेसिगनेटेड (निर्दिष्ट) रूटर एक डेसिगनेटेड रूटर (DR) एक रूटर इंटरफेस है जिसे सभी रूटर्स एक विशेष मल्टीएक्सेस नेटवर्क सेगमेंट पर चुनते हैं तथा जिसे आम तौर पर ब्रॉडकास्ट मल्टीएक्सेस माना जाता है। विशेष तकनीकें, जो अक्सर विक्रेता पर निर्भर है, DR प्रक्रियाओं को नॉनब्रॉडकास्ट मल्टी एक्सेस मीडिया (NBMA) पर सहायक हो सकती हैं। आमतौर पर NBMA सबनेट के अकेले वर्चुअल सर्किट को अकेले पॉइंट टू पॉइंट लाइन में कॉन्फ़िगर करना बुद्धिमत्ता है जिसके लिए इम्प्लीमेंटेशन-डिपेंडेंट तकनीकें प्रयुक्त होती हैं। DR को OSPF रूटर के प्रकार न समझें. एक रूटर के कुछ इंटरफेस डेसिगनेटेड (DR) हो सकते हैं, कुछ बैकअप डेसिगनेटेड (BDR) और कुछ नॉन-डेसिगनेटेड हो सकते हैं। यदि किसी सबनेट पर कोई रूटर DR या BDR नहीं है तो DR को पहले चुना जाता है तथा एक से अधिक BDR होने पर अगला चुनाव होता है।RFC 2328, पृष्ठ 75 DR का चुनाव निम्नलिखित पूर्वनिर्धारित मानदंडों के आधार पर किया जाता है। एक OSPF रूटर पर अगर प्राथमिकता 0 पर सैट हो, तो इसका मतलब है कि यह कभी भी एक DR या BDR (बैकअप डेसिगनेटेड रूटर) नहीं बन सकता. जब एक DR विफल होता है और BDR उसका स्थान ग्रहण करता है तो प्रतिस्थापन (रिप्लेसमेंट) BDR के लिए चुनाव होता है। सर्वोच्च प्राथमिकता के साथ हैलो पैकेट भेजने वाला रूटर चुनाव जीतता है। यदि दो या अधिक रूटर्स सर्वोच्च प्राथमिकता की सैटिंग के साथ टाई करते हैं तो सबसे अधिक RID (रूटर ID) के साथ हैलो भेजने वाला रूटर जीतता है। ध्यान दें: एक RID सर्वोच्च लोजिकल (लूपबैक) IP एड्रेस है जो एक रूटर के अनुरूप है, अगर कोई लोजिकल/ लूपबैक IP एड्रेस सैट न हो तो रूटर अपने सक्रिय इंटरफेस पर सर्वोच्च IP एड्रेस का उपयोग करता है। (जैसे 192.168.0.1, 10.1.1.2 से बड़ा है।) आमतौर पर दूसरे नंबर पर सर्वोच्च प्राथमिकता वाला रूटर BDR बन जाता है। प्राथमिकता मूल्यों की सीमा 0 - 255 के बीच होती है जिसमें एक उच्च मूल्य के साथ DR या BDR बनने की संभावना में वृद्धि हो जाती है। अगर एक उच्च प्राथमिकता वाला OSPF रूटर चुनाव के बाद ऑनलाइन आता है तो यह तब तक DR या BDR नहीं बनेगा जब तक कि (कम से कम) वर्तमान DR और BDR असफल नहीं होते. अगर वर्तमान DR फ़ेल हो जाता है तो वर्तमान BDR नया DR बन जाता है और दूसरे BDR को चुनने के लिए एक नया चुनाव होता है। अब यदि ये नया DR फ़ेल होता है तथा पुराना DR उपलब्ध है तब भी BDR ही DR बनता है। DR का उद्देश्य रूटिंग अपडेट के लिए स्रोत उपलब्ध करा के नेटवर्क ट्रैफिक को कम करना है। DR नेटवर्क की पूरी टोपोलॉजी की तालिका बनाता है तथा मल्टीकास्ट के द्वारा दूसरे रूटर्स को अपडेट भेजता है। एक क्षेत्र में सभी रूटर्स DR के साथ एक गुलाम/मालिक के सम्बन्ध कायम कर लेते हैं। वे केवल समीपवर्ती DR और BDR के साथ ही ऐसा करते हैं। जब भी रूटर एक अपडेट भेजता है, यह DR और BDR के मल्टीकास्ट एड्रेस 224.0.0.6 पर भेजता है। इसके पश्चात् DR क्षेत्र के अन्य सभी रूटर्स को मल्टीकास्ट एड्रेस 224.0.0.5 पर अपडेट भेजता है। इस तरह सभी रूटर्स को निरंतर एक दूसरे को अपडेट नहीं करना पड़ता और इसके बजाए एक ही स्रोत से अपने सभी अपडेट प्राप्त कर सकते हैं। मल्टीकास्टिंग का उपयोग नेटवर्क लोड को और कम कर देता है। DR और BDR हमेशा तैयार रहते हैं/ ब्रॉडकास्ट नेटवर्क (ईथरनेट) पर चुने जाते हैं। DR NBMA (नॉन ब्रॉडकास्ट मल्टीएक्सेस) नेटवर्क पर भी चुने जा सकते हैं जैसे कि फ़्रेम रिले या एटीएम. DR या BDR पॉइंट टू पॉइंट लिंक (जैसे कि पॉइंट टू पॉइंट WAN कनेक्शन) पर नहीं चुने जाते क्योंकि लिंक के किसी एक छोर पर दो रूटर्स पूरी तरह से पास पास होने चाहियें तथा उनके बीच की बैंडविड्थ और नहीं सुधारी जा सकती. बैकअप डेसिगनेटेड रूटर बैकअप डेसिगनेटेड रूटर (BDR) एक रूटर है जो वर्तमान डेसिगनेटेड रूटर में समस्या आने या उस के फ़ेल होने पर डेसिगनेटेड रूटर बन जाता है। BDR आखिरी चुनाव के समय दूसरी सर्वोच्च प्राथमिकता वाला OSPF रूटर है। OSPF पैकेट + बिट्स 0-7 8-15 16-18 19-31 0 वर्ज़न प्रकार पैकेट की लंबाई32 रूटर आईडी 64 क्षेत्र आईडी 96 चेकसम प्रमाणीकरण के प्रकार 128 प्रमाणीकरण 160 प्रमाणीकरण 192 नेटवर्क मास्क 224 हैलो इंटरवल विकल्प रूटर प्राथमिकता 256 रूटर डैड इंटरवल 288 निर्दिष्ट रूटर 320 बैकअप के लिए निर्दिष्ट रूटर 352 नज़दीकी आईडी 384 ... OSPF का ब्रॉडकास्ट मल्टीपल एक्सेस टोपोलोजी में प्रयोग पड़ोसी रूटर से सम्बन्ध डायेनेमिक रूप से मल्टी कास्ट हैलो पैकेट 224.0.0.5 पर भेज कर बनते हैं। एक DR और BDR सामान्य तौर पर चुने जाते हैं और सामान्य रूप से कार्य करते हैं। NBMA टोपोलोजी में OSPF का प्रयोग जैसा कि 2328 RFC में वर्णित है, NBMA टोपोलोजी में OSPF के लिए निम्नलिखित दो आधिकारिक प्रकार हैं: नॉन ब्रॉडकास्ट पॉइंट टू मल्टीपॉइंट सिस्को ने NBMA टोपोलोजी में OSPF के लिए तीन और प्रकार परिभाषित किये हैं: पॉइंट टू मल्टीपॉइंट नॉन ब्रॉडकास्ट ब्रॉडकास्ट पॉइंट टू पॉइंट क्रियान्वयन 6WINDGate, 6WIND से OSPFv2 और OSPFv3 सहित कॉमर्शियल एम्बेडेड ओपन सोर्स रूटिंग मॉड्यूल व्याटा, एक कॉमर्शियल ओपन सोर्स रूटर/फ़ायरवॉल. GNU ज़ेबरा, OSPF को स्पोर्ट करने वाले यूनिक्स सिस्टम के लिए एक GPL रूटिंग कुआग्गा, यूनिक्स सिस्टम के लिए जीएनयू ज़ेबरा का एक भाग OpenBSD, में एक OSPF कार्यान्वयन भी शामिल है XORP, एक रूटिंग सुइट RFC2328(OSPFv2) और RFC2740(OSPFv3) दोनों को IPv4 और IPv6 के लिए लागू करती है। बर्ड RFC2328 OSPF को लागू करता है GateD परियोजना जिसमें एक RFC1583 OSPF कार्यान्वयन (मैरीलैंड विश्वविद्यालय द्वारा UMD OSPF) शामिल है। रूटिंग और रिमोट एक्सेस सर्विस विन्डोज़ NT 4.0, विन्डोज़ 2000, विन्डोज़ XP और विन्डोज़ सर्वर 2003 में OSPFv2 को लागू करती है। परीक्षण उपकरण म्यू डाईनेमिक्स सर्विस विश्लेषक को एक ओपन सोर्स OSPF में 0-डे समस्या खोजने का श्रेय दिया गया था। दूसरे परीक्षण उपकरण भी उपयोगिता तथा लोड या तनाव की जांच के लिए बड़े पैमाने पर प्रयुक्त होते हैं जैसे इक्सिया कम्युनिकेशन और एजीलेंट टेक्नोलॉजीज के उपकरण. उपयोग OSPF व्यापक रूप से तैनात होने वाला पहला प्रोटोकॉल है जो कुछ सेकेंड में एक नेटवर्क को जोड़ सकता है और बाधा रहित रूट की गारंटी देता है। इसमें कई विशेषताएं है जिन से रूट के प्रक्षेपण के दौरान नीतियों को लागू करने की अनुमति मिलती है इसलिए इसका प्रयोग लोकल, लोड बांटने के लिए तथा IS-IS से ज्यादा चुनिन्दा रूट इंपोर्ट करने के लिए किया जाना चाहिए। इसके विपरीत IS-IS को एक स्थिर नेटवर्क में लोअर ओवरहैड के लिए नियोजित किया जा सकता है, जिसका प्रयोग आम तौर पर व्यापारिक नेटवर्क से ज्यादा ISP में होता है। कुछ ऐतिहासिक दुर्घटनाओं की वजह से IS-IS ISP के लिए प्राथमिक IGP बन गया है, लेकिन अब ISP, पहले एक सर्विस प्रोवाईडर की आवश्कताओं के अनुसार ISIS के लाभ तथा हानि की गणना के पश्चात्, OSPF को उसकी विशेषताओं के अधिक प्रभावी होने की वजह से चुन सकते है। Howard Berkowitz OSPF Goodies for ISPs http://www.nanog.org/meetings/nanog17/abstracts.php?pt=MTE0OSZuYW5vZzE3&nm=nanog17 North American Network Operators Group NANOG 17 1999 OSPFforISPs Montreal 16 नवंबर 2009 24 दिसंबर 2017 https://web.archive.org/web/20171224161727/http://www.6wind.com/ dead Dave Katz OSPFvsISIS OSPF and IS-IS: A Comparative Anatomy http://www.nanog.org/meetings/nanog19/abstracts.php?pt=MTA4NCZuYW5vZzE5&nm=nanog19 North American Network Operators Group NANOG 19 2000 Albuquerque 16 नवंबर 2009 8 फ़रवरी 2010 https://web.archive.org/web/20100208193256/http://www.nanog.org/meetings/nanog19/abstracts.php?pt=MTA4NCZuYW5vZzE5&nm=nanog19 dead जैसा कि बताया जा चुका है, एक्सटर्नल लिंक पर OSPF दूसरे IGPs से बेहतर लोड शेयरिंग कर सकता है। जब एक आईएसपी के डिफ़ॉल्ट रूट को OSPF में टाइप 1 बाह्य रूट के रूप में तथा दी गयी एक्सटर्नल लागत में मल्टीपल ASBRs द्वारा प्रवाहित किया जाता है तो दूसरे रूटर्स अपने स्थान से ASBRs के पास कम से कम पाथ लागत के साथ जायेंगे. बाह्य लागत को समायोजित करके इसे और बेहतर किया जा सकता है। इसके विपरीत, यदि अलग अलग ISPs से डिफ़ॉल्ट मार्ग अलग बाह्य लागत से, टाइप II एक्सटर्नल रूप में प्रवाहित होते हैं, तो कम लागत वाला डिफ़ॉल्ट बाहर जाने का प्राथमिक रास्ता बन जाता है और और अधिक लागत वाला सिर्फ बैकअप बन जाता है। RFC इतिहास 1989, अक्टूबर - पहले 1131 RFC के रूप में एक प्रस्ताव मानक के रूप में रखा गया। 1994, OSPF NSSA विकल्प, RFC 1587. 1994, मार्च - मल्टीकास्ट एक्सटेंशन से OSPF RFC 1584 के रूप में प्रस्तावित. 1997, जुलाई - OSPF संस्करण 2, RFC 2178 के रूप में में प्रस्तावित 1998, अप्रैल - OSPF संस्करण 2, RFC 2328 में अपडेट इंटरनेट स्टैंडर्ड 54. 1999, दिसम्बर - OSPFv3 - IPv6 के लिए OSPF, RFC 2740. 2003 जनवरी - OSPF NSSA विकल्प को अपडेट किया गया, RFC 3101 2005, अक्टूबर - विशिष्ट OSPF संस्करण 2 पैकेट तथा बाधा से बचाव का प्राथमिक उपचार, RFC 4222. 2006 दिसम्बर - OSPF संस्करण 2 प्रबंधन सूचना बेस, RFC 4750 2007, मई - OSPF संस्करण 3 प्रबंधन सूचना बेस का ड्राफ्ट 2008, जुलाई - IPv6 के लिए OSPF, RFC 5340 (RFC 2740 समाप्त) 2009 फ़रवरी - अनियोजित नेटवर्क, RFC 5449 के लिए OSPF मल्टी पॉइंट रिले (MPR) एक्सटेंशन इन्हें भी देखें बेहतर इन्टीरियर गेटवे रूटिंग प्रोटोकॉल मैश नेटवर्किंग रूटिंग रूट विश्लेषण सन्दर्भ आगे पढ़ने के लिए एंड्रयू कोल्टन,"सिस्को रूटर्स के लिए OSPF" जेफ डोयल, जेनिफर कैरोल, "टीसीपी/आईपी रूटिंग", Volume 1, द्वितीय संस्करण जॉन टी. मोए, OSPF: इंटरनेट रूटिंग प्रोटोकॉल का विश्लेषण. विलियम आर पर्खुर्स्त, सिस्को OSPF कमांड और कॉन्फिगरेशन पुस्तिका. ISBN 978-1-58705-071-8 http://www.netcordia.com/resources/tech-tips/configuring-ospf-authentication.asp Configuring OSPF Authentication 2009-09-10 https://web.archive.org/web/20091106095521/http://www.netcordia.com/resources/tech-tips/configuring-ospf-authentication.asp 6 नवंबर 2009 dead बाहरी कड़ियाँ IETF OSPF कार्य समूह OSPF मूल बातें OpenOSPFD का डिजाईन तथा कार्यान्वयन (पेपर) OpenOSPFD का डिजाईन तथा कार्यान्वयन (प्रेजेंटेशन) सिस्को OSPF सिस्को OSPF क्षेत्र और वर्चुअल लिंक्स OSPF ट्यूटोरियल OSPF V2 का सारांश OSPF तथा IS-IS : डेव काट्ज़, जुनिपर द्वारा एक तुलनात्मक विश्लेषण IS-IS और OSPF में विभिन्नता पर चर्चा (विश्वास मनराल, मानव भाटिया और यासुहिरो ओहारा) मेनफ्रेड लिंडनर के डाटा कम्युनिकेशन पर व्याख्यान - भाग OSPF का आधार मेनफ्रेड लिंडनर के डाटा कम्युनिकेशन पर व्याख्यान - भाग OSPF क्षेत्र टीसीपी / आईपी गाइड - OSPF श्रेणी:इंटरनेट प्रोटोकॉल श्रेणी:इंटरनेट मानक श्रेणी:रूटिंग प्रोटोकॉल श्रेणी:लिंक प्रोटोकॉल