411 REFERENCE · Wikipedia
.mil
Reference material by Wikipedia contributors. This retains its source identity and is not 411 news reporting.
Internet top-level domain
March 2021
March 2021
.mil #FC0 United States Department of Defense Logo (2021) Icon.svg 1985 1 1 Sponsored top-level domain Active Yes Defense Information Systems Agency DoD Network Information Center Military entities Agencies, services and divisions of the United States Department of Defense Restricted to eligible agencies Divisions of particular services usually have third and higher level subdomains, such as within army.mil for United States Army sites. RFC 920; RFC 1591 None https://www.war.gov/Resources/Register-a-Site/tab/Website/ 100px
The domain name mil is the sponsored top-level domain (sTLD) in the Domain Name System of the Internet for the United States Department of Defense and its subsidiary or affiliated organizations. The name is derived from military. It was one of the first top-level domains, created in January 1985.RFC 920 - Domain Requirements https://tools.ietf.org/html/rfc920 J. Postel J. Reynolds The Internet Engineering Task Force October 1984 10.17487/RFC0920 free As in the case with .gov, the United States is the only country that has a top-level domain for its military, a direct result of the United States' military's role in the creation of the Internet.
Other countries often use second-level domains for this purpose, e.g., mod.uk for the United Kingdom's Ministry of Defence.
Despite having a dedicated top-level domain, the US military also uses com domains for some of its recruitment sites, such as goarmy.com, as well as for the Defense Commissary Agency's website www.commissaries.com and most non-appropriated fund instrumentalities such as military MWR organizations and military exchanges. Also, the military uses edu domains for its service academies: the United States Military Academy, United States Coast Guard Academy, United States Naval Academy, and the United States Air Force Academy can all be reached using either an edu or a mil domain name. The official athletic program sites of the three academies that are members of NCAA Division I (Army, Navy, Air Force) use com domains, as well as Coast Guard, which is a member of NCAA Division III. The United States Department of Defense (also referred to as the Department of War) itself uses gov for its home page, with at least three second-level domains within mil (defense, dod, pentagon) redirecting to its domain name war.gov https://web.archive.org/web/20250905222920/https://www.war.gov/ September 5, 2025 (formerly dod.gov).
The United States Coast Guard, like other military services, uses the mil domain, although during statutory peacetime the service falls under the United States Department of Homeland Security.United States Coast Guard Regulations 1992 http://www.uscg.mil/directives/cim/5000-5999/CIM_5000_3B.pdf US Coast Guard
The mil domain is also used by NORAD, a bi-national military alliance between the US and Canada.
References
External links
IANA .mil whois information
Category:Sponsored top-level domains
Category:Military terminology of the United States
Category:Domain names in the United States
Category:Internet in Canada
Category:Internet properties established in 1985