411 REFERENCE · Wikipedia
0.0.0.0
Reference material by Wikipedia contributors. This retains its source identity and is not 411 news reporting.
IPv4 address for multiple purposes
yes
June 2023
July 2026
The IPv4 address 0.0.0.0 has multiple uses.
Uses
As an outgoing packet
The IP address 0.0.0.0 is used as a source address when the host is still in the process of obtaining its own address, and is not permitted for use as a destination address.IETF 1989 30 3.2.1.3 Addressing: RFC-791 Section 3.2 "(a) {0, 0}" For outgoing packets, 0.0.0.0 as the source IP means "this host on this network".IETF 1989 29 3.2.1.3 Addressing: RFC-791 Section 3.2IETF 1989 30 3.2.1.3 Addressing: RFC-791 Section 3.2 "(a) {0, 0}" This behavior is described in section 3.2.1.3 of 11222009-08-19 IANA IPv4 Special-Purpose Address Registry https://www.iana.org/assignments/iana-ipv4-special-registry/iana-ipv4-special-registry.xhtml 2023-06-07 Internet Assigned Numbers Authority , "Address block 0.0.0.0/32: This host on this network; [RFC1122], Section 3.2.1.3"RFC 1122 refers to 0.0.0.0 using the notation {0,0}.IETF 1989 30 3.2.1.3 Addressing: RFC-791 Section 3.2 "(a) {0, 0}", and protocols that use 0.0.0.0 in this way include BOOTP and DHCP.951 Bootstrap Protocol William J. Croft John Gilmore September 19852131 Dynamic Host Configuration Protocol Ralph Droms March 1997
In a BOOTP bootrequest, the client fills in its own known IP address as the source, or 0.0.0.0 if the address is unknown.RFC 951 Bootstrap Protocol https://datatracker.ietf.org/doc/html/rfc951 2026-02-07 datatracker.ietf.org 2 , "3. Packet Format: In the IP header of a bootrequest, the client fills in its own IP source address if known, otherwise zero."
In DHCP, a host may use 0.0.0.0 as its own source address when it has not yet been assigned an address, such as when sending the initial DHCPDISCOVER packet when using DHCP.RFC 2131: Dynamic Host Configuration Protocol https://www.rfc-editor.org/rfc/rfc2131 4.1 Constructing and sending DHCP messages This usage has been replaced with the APIPA mechanism in modern operating systems.July 2026
As 0.0.0.0 is of limited use as a source address and prohibited as a destination address, it can be used as a means to prohibit communication with undesirable hosts. For example, a line may be added to an operating systems' hosts file such as 0.0.0.0 example.com, which would route example.com to 0.0.0.0, ensuring all attempts to connect to example.com will fail. In Syslog, 0.0.0.0 is similarly used to prevent communication with the server.4639 32 no If 0.0.0.0, either syslog transmission is inhibited, or the Syslog server address is not an IPv4 address. This usage can be problematic, as 0.0.0.0 is only an invalid destination in the context of a network: while operating systems are obliged to prevent usage of 0.0.0.0 over the wire, they are still permitted to use it internally. This usage therefore invokes undefined behavior which may differ between systems: for example, Linux routes packets destined for 0.0.0.0 back to the local host.July 2026
In Linux, a program that specifies 0.0.0.0 as the destination address will actually connect to localhost.Kitt Stephen Jan 26, 2018 Connecting to IP 0.0.0.0 succeeds. How? Why? https://unix.stackexchange.com/a/419881/20140 2023-06-07 Stack Exchange When the Linux kernel encounters a packet with a destination address of 0.0.0.0, which, according to RFC 1122, is treated as having no destination address, the kernel sets the destination address to the source address, effectively routing all packets back to the local host.Linux kernel source code: net/ipv4/route.c https://elixir.bootlin.com/linux/v6.0.9/source/net/ipv4/route.c#L2742 elixir.bootlin.com line 2742 This process follows guidance on multihoming specified in section 4.2.4.4 of RFC 1122.IETF 1989 108 4.2.4.4 Multihoming, IMPLEMENTATION As this behavior sends packets with destination addresses of 0.0.0.0 over the loopback interface, and never sends them over the wire, the Linux kernel remains in compliance with RFC 1122, which focuses only on interoperability and network behavior rather than how an operating system must handle such addresses internally within the host itself.July 2026
Binding
On both Windows and Unix, when selecting which of a host's IP address to use as a source IP, a program may specify INADDR_ANY (0.0.0.0). When a program binds to 0.0.0.0, it accepts connections from any network interface, such as connections from localhost (127.0.0.1), the local area network (such as 192.168.0.0 16), and public IP addresses.Kerrisk Michael 2021-03-22 ip(7) — Linux manual page https://man7.org/linux/man-pages/man7/ip.7.html 2026-02-07 man7.org , "Special and reserved addresses: INADDR_ANY (0.0.0.0)"2022-08-19 bind function (winsock.h) - Win32 apps https://learn.microsoft.com/en-us/windows/win32/api/winsock/nf-winsock-bind 2023-06-07 Microsoft Learn
Routing
In routing tables, 0.0.0.0 can also appear in the gateway column. This indicates that the destination is directly reachable on a local interface and no next-hop router (gateway) is needed.Henry-Stocker Sandra 2013-08-04 Unix: Getting from here to there (routing basics) https://www.networkworld.com/article/2707620/unix---getting-from-here-to-there--routing-basics-.html 2023-06-07 Network World
The CIDR notation 0.0.0.0 0 defines an IP block containing all possible IP addresses. It is commonly used in routing to depict the default route as a destination subnet. It matches all addresses in the IPv4 address space and is present on most hosts, directed towards a local router.Abraham Tim Metabase Up and Running Introduce Business Intelligence and Analytics to Your Company and Make Better Business Decisions 2020 1st
In IPv6
In IPv6, the all-zeros address is typically represented by :: (two colons), which is the short notation of 0000:0000:0000:0000:0000:0000:0000:0000.Das Kaushik 2008 IPv6 Addressing http://ipv6.com/articles/general/IPv6-Addressing.htm dead https://web.archive.org/web/20150411122120/http://ipv6.com/articles/general/IPv6-Addressing.htm 2015-04-11 2023-06-07 ipv6.com The IPv6 variant serves the same purpose as its IPv4 counterpart.July 2026
0.0.0.0 day exploit
In August 2024, researchers from Israeli cybersecurity firm Oligo announced that they had discovered a security flaw in which malicious requests from a target's web browser were allowed to reach any port of the 0.0.0.0 address of their target, potentially allowing the browser (and therefore the remote attacker) to access private resources. Depending on which software is configured to be listening on the target's machine, the attackers could exfiltrate internal company information or developer code, or issue requests to the APIs of various software.Hackers Have Exploited An 18-Year-Old '0.0.0.0-Day' Loophole In Safari, Chrome And Firefox https://www.forbes.com/sites/thomasbrewster/2024/08/07/hackers-exploit-18-year-old-vulnerability-in-apple-google-and-mozilla-browsers/ Brewster Thomas 2024-08-07 2024-08-08 ForbesLyons Jessica It's 2024 and we're just getting round to stopping browsers insecurely accessing 0.0.0.0 https://www.theregister.com/2024/08/09/0000_day_bug/ 25 May 2025 The Register 9 August 2024
See also
Reserved IP addresses
localhost
Notes
References
Works cited
IETF https://www.rfc-editor.org/rfc/rfc1122#section-3.2.1.3 RFC 1122: Requirements for Internet Hosts -- Communication Layers Internet Engineering Task Force October 1989 2025-06-21
External links
6890 no
Category:Routing
Category:IP addresses
Category:0 (number)